Jump to content


Unable to set default download action for Firefox


  • Please log in to reply
14 replies to this topic

#1 OFFLINE   Bob Coleman

Bob Coleman

    New Kid

  • Members
  • Pip
  • 9 posts

Posted 21 May 2007 - 02:34 PM

I'm using Firefox 2.0.0.3 on Windows XP Home Edition SP2.I've recently noticed that I'm unable to set the default handling by filetype for files being downloaded.One specific example is downloading pictures from webshots.com .  When I initiate a download, I get a dialog with radio buttons for
  • Open with Webshots Extensiion (default)
  • Save to disk
The "Open with ..." is already selected and there is also an already checked checkbox for "Do this automatically for files like this from now on".  If I click OK, the proper action occurs, but the next time, the same dialog appears despite the checked "Do this automatically ...".This particular behavior only recently started happening.  Until recently, the desired action did happen automatically without the dialog being presented.Of longer standing is a similar issue involving downloading banking transactions to Quicken.  In this case, the radio button "Open with Quicken Launcher (default)" is selected, but the "Do this automatically ..." choice can't be checked (it's grayed out).  So again, I always have to select OK.

#2 OFFLINE   Temmu

Temmu

    The Assimilator

  • Forum MVP
  • 12,543 posts

Posted 23 May 2007 - 01:25 PM

hi, bob and welcome!if you were able to make those choices before and now cannot, i'd first suspect some sort of malware that has grabbed control of that.i'd scan with an av product (can even use one online)and then with "adaware" and "spybot search and destroy"post back if you have any questions about this or if you find any bugs.let us know!
Posted Image

#3 OFFLINE   Bob Coleman

Bob Coleman

    New Kid

  • Members
  • Pip
  • 9 posts

Posted 23 May 2007 - 04:05 PM

Malware is a reasonable assumption, but I don't think so.I've run both "Adaware" and "Spybot Search and Destroy" since the changed behavior started happening.  Probably even more to the point, I've had both Norton AntiVirus and Counterspy constantly running and have been running complete system scans with both several times a week.I actually made some effort to narrow down the timing of the changed behavior.  I have a multi-boot setup with two copies of WinXP, one of which I seldom use.  I also have almost daily image backups of the one  do use going back two weeks at any given time.  I restored a backup that I'm almost certain was taken before the problem characteristics changed and also booted the seldom used copy of XP.  I was quite surprised to find that the new behavior still existed.I do have my Firefox profile on a data partition separate from the OS partition, but I restored that partition to an old state also with no luck.I don't know if  really believe this, but all that activity almost seems to implicate some external source of the problem such as possibly website the files are coming from.

#4 OFFLINE   Bob Coleman

Bob Coleman

    New Kid

  • Members
  • Pip
  • 9 posts

Posted 23 May 2007 - 04:27 PM

Looks like this won't be solved here.  It seems to be a somewhat well known problem.https://bugzilla.moz...g.cgi?id=331259

#5 OFFLINE   LilBambi

LilBambi

    Australisches Googler

  • Forum Admins
  • 22,546 posts

Posted 23 May 2007 - 07:34 PM

BEFORE DOING ANYTHING, you might want to backup your Firefox profile directory so you can restore it if it doesn't work as anticipated or to give you an opportunity to try one of the other options.AFTER BACKING UP YOUR PROFILE; I would suggest typing about:config in the address bar, then in the search bar for about:config, type download.From the list choose, "browser.download.hide_plugins_without_extensions" and click it to change it from true to false.Then go to the Menu (in Windows) choose Tools, Options*. Under the Content section, there should be an area called File Types at the bottom. Choose the Manage button to the right.* (Mac) choose Firefox, Preferences, Content section, (Linux) File, Preferences, Content section.Look for and highlight (if you can locate it), the particular file type that handles the Webshots images, and click the Change action button.Now here's where it gets dicey (and why you backed up your profile)...You are given the opportunity to choose what you want to do with a given file type, but there is no option in there for ASK on each instance of that file type.However, if no file type exists for the webshots file extension, and there isn't a specific action for that file type, Firefox will ask you what you want to do on the next attempt to download/run the file type.So, with your profile safely backed up, delete the file type for the webshots extension.At that point, the next time you choose a file with that type of extension, you will be presented with an opportunity to choose the program and whether you want it to always do this particular action.You may have to close and open Firefox again before it takes effect...not sure. Been awhile.This is how I gave myself the opportunity to choose what to do with things like .m3u files. Firefox now gives me a choice of choosing a program (with the last program as 'default,' or to save the file, and a place to choose whether it should always do this. I don't click that. This works very similar at that point, to the way Windows does with File types when it doesn't have a specific type of program to open a file type. And it will prompt you each time for what you want to do (generally giving you the program that you chose last as the first program option).Not sure if it will work with webshots or not. There may be a registry entry for Webshots that is forcing this action. If this doesn't work, you might want to check that too.Hope this helps.
Bambi
AKA Fran

Posted Image
My Public Key for Email :: BambisMusings Blog :: Fran's Computer Services Blog :: MyPassionIsBooks Blog :: 5BuckReview :: CNIRadio
"The Net interprets censorship as damage and routes around it." ~John Gilmore (Time Magazine, Dec 6, 1993)

#6 OFFLINE   Bob Coleman

Bob Coleman

    New Kid

  • Members
  • Pip
  • 9 posts

Posted 24 May 2007 - 06:06 PM

Thanks for the ideas, but they don't help.You mention that you do not choose the option to always do the same thing for the particular type of file.  My issue of the moment is that I do always want to do the same thing but checking that option doesn't "stick".  I have to click OK every time even though the option is checked every time.Interestingly, in the list of actions in the Firefox UI, the action is simply "Open with" followed by nothing.  Nevertheless, the "Opening ..." dialog always comes up with "Webshots.Extension (default)" as the action (and Do this automatically ..." checked), but Firefox doesn't take that action until I click OK or press Enter.I'm now pretty well convinced, based on the reference given in my previous post, that this is known Firefox issue and/or some configuration problem on the server from which the files are being downloaded.

#7 OFFLINE   Webb

Webb

    Multithreader

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,066 posts

Posted 24 May 2007 - 08:42 PM

Reset it and start over.In Windows cut & paste C:\Program Files\Mozilla Firefox\defaults\profile\mimetypes.rdf into your Fx profile and overwrite the existing file.
The 9000 series is the most reliable computer ever made. No 9000 computer has ever made a mistake or distorted information. We are all, by any practical definition of the words, foolproof and incapable of error. - HAL-9000

You know, this used to be a helluva good country. I don't understand what's gone wrong with it.  - George Hanson, 1969

A bad day at golf is better than a good day at work.


Posted Image
Jim

#8 OFFLINE   Bob Coleman

Bob Coleman

    New Kid

  • Members
  • Pip
  • 9 posts

Posted 25 May 2007 - 03:28 PM

OK, let's make sure I understood this.  My Firefox profile has a non-standard name and is in a non-standard location.I shutdown Firefox, made a copy of my profile, then copied C:\Program Files\Mozilla Firefox\defaults\profile\mimetypes.rdf to my profile replacing the existing mimetypes.rdf .I then re-started Firefox, went to Tools -> Options -> Content -> Manage and verified that there was no entry for the extension in question (WBZ).However, after a couple of downloads, I'm back to the same state as before ("Opening ..." dialog always appears with "Do this automatically ..." checked.So I restored my profile to its previous state.Actually, I wasn't surprised that this didn't work because I had previously tried using a newly created profile without success.I had also tried simply removing the relevant entry from Tools -> Options -> Content -> Manage .I'm really beginning to suspect that something recently changed on the webshots.com site that caused this to start happening.

#9 OFFLINE   Tushman

Tushman

    Forum Fiend

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 1,804 posts

Posted 25 May 2007 - 03:42 PM

View PostBob Coleman, on May 25 2007, 02:28 PM, said:

My Firefox profile has a non-standard name and is in a non-standard location.
Then I would make sure that it shows appropriately when you type in "about:config".

#10 OFFLINE   Bob Coleman

Bob Coleman

    New Kid

  • Members
  • Pip
  • 9 posts

Posted 25 May 2007 - 04:56 PM

View PostTushman, on May 25 2007, 03:42 PM, said:

Then I would make sure that it shows appropriately when you type in "about:config".
I have no doubt the profile is being used, if that's what you mean.

#11 OFFLINE   Webb

Webb

    Multithreader

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,066 posts

Posted 25 May 2007 - 05:03 PM

It is not recommended but you can manually edit mimetypes.rdf with a text editor.Link

Quote

Additional options    * NC:alwaysAsk - true (always ask which action to perform) or false (don't ask which action to perform)

The 9000 series is the most reliable computer ever made. No 9000 computer has ever made a mistake or distorted information. We are all, by any practical definition of the words, foolproof and incapable of error. - HAL-9000

You know, this used to be a helluva good country. I don't understand what's gone wrong with it.  - George Hanson, 1969

A bad day at golf is better than a good day at work.


Posted Image
Jim

#12 OFFLINE   Bob Coleman

Bob Coleman

    New Kid

  • Members
  • Pip
  • 9 posts

Posted 25 May 2007 - 06:07 PM

Granted that I don't completely understand this, but here are a few lines from the file (left justified in the process of copying them here):

Quote

<RDF:Description RDF:about="urn:mimetype:handler:application/x-webshots"                   NC:saveToDisk="false"                   NC:alwaysAsk="false"                   NC:useSystemDefault="true">    <NC:externalApplication RDF:resource="urn:mimetype:externalApplication:application/x-webshots"/>  </RDF:Description>
so according to this, I'd think it's not supposed to be asking, but it is.

#13 OFFLINE   Webb

Webb

    Multithreader

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,066 posts

Posted 25 May 2007 - 07:50 PM

I'm confused.  What do you want it to do with which filetype?My mimetypes.rdf has no entry for x-webshots.  What kind of file is it?  What is the system default?
The 9000 series is the most reliable computer ever made. No 9000 computer has ever made a mistake or distorted information. We are all, by any practical definition of the words, foolproof and incapable of error. - HAL-9000

You know, this used to be a helluva good country. I don't understand what's gone wrong with it.  - George Hanson, 1969

A bad day at golf is better than a good day at work.


Posted Image
Jim

#14 OFFLINE   Tushman

Tushman

    Forum Fiend

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 1,804 posts

Posted 25 May 2007 - 08:18 PM

View PostBob Coleman, on May 25 2007, 03:56 PM, said:

I have no doubt the profile is being used, if that's what you mean.
I suggested you type in the about:config because I thought you may have manually renamed the default profile folder through Windows Explorer rather than changing it through Firefox.

#15 OFFLINE   Bob Coleman

Bob Coleman

    New Kid

  • Members
  • Pip
  • 9 posts

Posted 26 May 2007 - 02:33 PM

View PostWebb, on May 25 2007, 07:50 PM, said:

I'm confused.  What do you want it to do with which filetype?My mimetypes.rdf has no entry for x-webshots.  What kind of file is it?  What is the system default?
To the degree that I understand this, I wouldn't expect your mimetypes.rdf to have an entry for x-webshots unless you had downloaded photos from webshots.com and/or have the webshots desktop application installed.See first post for some more information.Ideally what I want (and what happened until recently) is that when I download a photo from webshots, the webshots application automatically processes it and adds it to a photo collection within webshots.When I started this, I thought it might be an issue with downloading files in general.  I now think it's probably unique to the webshots.com site.  I doubt you could reproduce the issue without installing the webshots application (available from webshots.com, but I wouldn't expect you to do that).




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users