Jump to content


GDM Acting Up


  • Please log in to reply
8 replies to this topic

#1 OFFLINE   raymac46

raymac46

    Discussion Deity

  • Forum MVP
  • 3,614 posts

Posted 07 May 2018 - 03:25 PM

After I updated my Thinkpad's Debian Stretch install, something went weird with the Gnome Display Manager I use to log in. After launch, the login screen would not show up - just a black screen. I could press Ctrl-Alt-F1 a couple of times and maybe the screen would appear. Or I could Ctrl-Alt-F2, get TTY2, log in and StartX to get the GNOME GUI.
I tried reinstalling and reconfiguring gdm3, gnome-session, xorg, and xserver-xorg without result. Finally, I gave up and just installed LightDM - which I use in Arch and like better anyway. That works fine - boot, get the login screen, start GUI.
I still don't know what's wrong with Gnome Display Manager but I don't want to reinstall Debian. Maybe I'll go with Ubuntu MATE if I have any more trouble.
Posted Image

Registered Linux User 445659

#2 OFFLINE   sunrat

sunrat

    Thread Kahuna

  • Forum Moderators
  • 5,510 posts

Posted 07 May 2018 - 11:30 PM

Does this help?
apt install haveged

Something to do with random blah blah entropy generator. :'(

http://forums.debian...137404&start=30
registered Linux user number 324659  ||    The importance of Reading The *Fine* Manual! :D
Posted ImagePosted ImagePosted ImagePosted Image
For the things we have to learn before we can do them, we learn by doing them.

#3 OFFLINE   saturnian

saturnian

    Multithreader

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,076 posts

Posted 08 May 2018 - 07:25 AM

Wow, I haven't seen this problem come up here (yet), and I have Stretch w/ GNOME on two machines, both using gdm3. Thanks for the info, sunrat.

#4 OFFLINE   raymac46

raymac46

    Discussion Deity

  • Forum MVP
  • 3,614 posts

Posted 08 May 2018 - 09:08 AM

Haven't dealt with entropy since my days studying thermodynamics, but sunrat's suggestion fixed the problem. :clap:
I still think I'll stay with LightDM though.
That is the reason I stick around here - somebody always knows a solution to my Linux problem. :teehee:
Posted Image

Registered Linux User 445659

#5 OFFLINE   securitybreach

securitybreach

    CLI Phreak

  • Forum Admins
  • 23,452 posts

Posted 08 May 2018 - 05:53 PM

Nice :thumbsup:
Posted ImagePosted Image Posted Image
CNI Radio/G+ Profile/Configs/PGP Key/comhack π

"Do you begin to see, then, what kind of world we are creating? It is the exact opposite of the stupid hedonistic Utopias that the old reformers imagined. A world of fear and treachery and torment, a world of trampling and being trampled upon, a world which will grow not less but more merciless as it refines itself. Progress in our world will be progress toward more pain." -George Orwell, 1984

#6 OFFLINE   raymac46

raymac46

    Discussion Deity

  • Forum MVP
  • 3,614 posts

Posted 09 May 2018 - 08:47 AM

I read another article that said if you have a more recent Intel or AMD cpu that supports a hardware random number generator you can install rng-tools with its associated daemon rngd instead of haveged.
According to cpuinfo my Ivy Bridge mobile processor has this capability as it shows the rdrand flag. However, the O/S can't detect this so systemd will not start rngd.service :'( .
No matter - haveged works just fine and has fixed the issue. :bounce:
After going through all this my own personal entropy had increased significantly. :w00tx100:

Edited by raymac46, 09 May 2018 - 09:09 AM.

Posted Image

Registered Linux User 445659

#7 OFFLINE   sunrat

sunrat

    Thread Kahuna

  • Forum Moderators
  • 5,510 posts

Posted 09 May 2018 - 07:25 PM

There was a Stretch kernel update yesterday which may have addressed this problem. I can't confirm as I don't use GDM.
registered Linux user number 324659  ||    The importance of Reading The *Fine* Manual! :D
Posted ImagePosted ImagePosted ImagePosted Image
For the things we have to learn before we can do them, we learn by doing them.

#8 OFFLINE   saturnian

saturnian

    Multithreader

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,076 posts

Posted 14 May 2018 - 02:57 AM

View Postraymac46, on 07 May 2018 - 03:25 PM, said:

Finally, I gave up and just installed LightDM - which I use in Arch and like better anyway.

Thank you for this comment. After thinking about it -- and, even though I didn't encounter the GDM bug here -- I switched from gdm3 to lightdm in one of my Stretch installations. I simply ran the following

$ sudo apt install lightdm lightdm-gtk-greeter-settings

Then I just followed the prompts. The lightdm-gtk-greeter-settings package provides the GUI, I guess, which is nice for configuring LightDM to taste.

Switching to LightDM actually solved a couple of other GDM-related annoyances in that installation.

#9 OFFLINE   raymac46

raymac46

    Discussion Deity

  • Forum MVP
  • 3,614 posts

Posted 14 May 2018 - 10:37 AM

Yes the GUI makes it very easy to set up LightDM - even choosing your own background is easy. With GDM it's a bear to get rid of the battleship gray background.
Posted Image

Registered Linux User 445659




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users